0xsp-Mongoose – Privilege Escalation Enumeration Toolkit

0xsp-Mongoose – Privilege Escalation Enumeration Toolkit

0xsp-Mongoose – Privilege

Using 0xsp mongoose you will be able to scan a targeted operating system for any possible way for privilege escalation attacks, starting from collecting information stage until reporting information through 0xsp Web Application API.
user will be able to scan different Linux os system at the same time with high performance, without spending time looking inside the terminal or text file for what is found, mongoose shorten this way by allowing you to send this information directly into web application friendly interface through easy API endpoint.
project is divided into two sections server & agent .
server has been coded with PHP(codeigniter) you need to install this application into your preferred environment, you can use it online or on your localhost. user is free to choice .also contribution to enhancing features are most welcomed.
Agent has been coded as ELF with Lazarus Free Pascal will be released with (32, 64 bit) while
executing Agent on targeted system with all required parameters. user is free to decide whether
willing to communicate with Server App to store results and explore them easily . or he can also
run this tool without Web API Connection.
Agent Usage

  1. make sure to give it executable permission chmod +x agent
  2. ./agent -h (display help instructions)

Leave a Reply